你好,游客 登录 注册 搜索
背景:
阅读新闻

This Android SDK requires Android Developer Toolkit version 20.0.0 or above -

[日期:2013-04-17] 来源:  作者: [字体: ]
 转自:http://blog.csdn.net/wh_19910525/article/details/7937971

This Android SDK requires Android Developer Toolkit version 20.0.0 or above

 

windows 下面安装Android虚拟机,有时候选择更新SDK后,在Eclipse preference里指向android_sdk_windows_x86时。会出现诸如This AndroidSDK requires  Android Developer Toolkit version 20.0.0or above这样的提示,而且虚拟机无法打开的情况,这是由于选择更新后,在 android_sdk_windows/tools/lib下的  plugin.prop文件里被变更为

# begin plugin.prop
plugin.version= 20.0.0
# end plugin.prop

Eclipse在查看该文件时,看到plugin.version=20.0.0,就认为当前的sdk需要20.00版本以上的插件,但是当前 的ADT插件还未来得及更新到20.0.0版本,但我们只想用以前旧的插件,最简单的方法就是将plugin.version的版本信息改为旧版本的版本号,诸如当前的ADT为 16.0.0.当前SDK的版本已经更新至20.0.0,我在误点更新之后,提示需要更新Android Developer Toolkit到20.0.0.0版本以上,而以前下下来的低版本的AndroidDeveloper Toolkit 却无法使用,查到后才发现是该文件的问题,修改plugin.version=16.0.0(我的旧的Android Developer Toolkit )保存,再重启一下Eclipse就能用以前旧的avd了。





收藏 推荐 打印 | 录入:admin | 阅读:
相关新闻